# CVE-2026-32718: Coolify read-scoped API tokens can perform state-changing validation operations

> Read-scoped API tokens in Coolify can perform state-changing validation operations due to missing authorization checks on mutating endpoints.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-f47p-xrgc-977v

## What is CVE-2026-32718?

CVE-2026-32718 is a medium-severity missing authorization vulnerability in coollabsio coolify, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. Prior to 4.0.0-beta.466, mutating API validation endpoints are guarded by read ability, allowing read-scoped API tokens to perform state-changing operations such as validating cloud tokens and servers. This issue is fixed in version 4.0.0-beta.466.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-32718?


## How do I fix CVE-2026-32718?

No fix has been published for CVE-2026-32718 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32718 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32718 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32718 and fix it if it is affected.

What it is: CVE-2026-32718 is a medium-severity missing authorization vulnerability in coollabsio coolify, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32718 exists.

Affected product: coollabsio coolify. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32718/ (Markdown: https://insights.sbomify.com/CVE-2026-32718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32718
- OSV: https://osv.dev/vulnerability/CVE-2026-32718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32718/
Summaries are generated and may contain mistakes; the official description above is the record.
