CVE-2026-32721 LuCI luci-mod-network: Possible XSS attack in WiFi scan on Joining Wireless Client modal
Attackers can inject malicious scripts via crafted SSIDs in the wireless scan modal, potentially compromising user sessions in OpenWrt LuCI.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-32721?
CVE-2026-32721 is a high-severity cross-site scripting vulnerability in Openwrt Openwrt, published on 19 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
LuCI is the OpenWrt Configuration Interface. Versions prior to both 24.10.5 and 25.12.0, contain a stored XSS vulnerability in the wireless scan modal, where SSID values from scan results are rendered as raw HTML without any sanitization. The wireless.js file in the luci-mod-network package passes SSIDs via a template literal to dom.append(), which processes them through innerHTML, allowing an attacker to craft a malicious SSID containing arbitrary HTML/JavaScript. Exploitation requires the user to actively open the wireless scan modal (e.g., to connect to a Wi-Fi access point or survey nearby channels), and only affects OpenWrt versions newer than 23.05/22.03 up to the patched releases (24.10.6 and 25.12.1). The issue has been fixed in version LuCI 26.072.65753~068150b.
Weakness: CWE-79
Which versions are affected by CVE-2026-32721?
It affects 2 products.
Products include Openwrt Luci, Openwrt Openwrt.
How do I fix CVE-2026-32721?
No fix has been published for CVE-2026-32721 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-32721 being exploited?
There is no known exploitation of CVE-2026-32721 in the wild and no public exploit code.
Other vulnerabilities in Openwrt Openwrt
Sources
Also known as GHSA-vvj6-7362-pjrw.