{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-32721 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-32721 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-32721 is a high-severity cross-site scripting vulnerability in Openwrt Openwrt, published on 19 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-32721 and fix it if it is affected.\n\nWhat it is: CVE-2026-32721 is a high-severity cross-site scripting vulnerability in Openwrt Openwrt, published on 19 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-32721 in the wild and no public exploit code.\n\nAffected product: Openwrt Openwrt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32721/ (Markdown: https://insights.sbomify.com/CVE-2026-32721/index.md)","id":"CVE-2026-32721","markdown":"https://insights.sbomify.com/CVE-2026-32721/index.md","name":"CVE-2026-32721","record":{"aliases":["GHSA-vvj6-7362-pjrw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenWrt LuCI interface","requires_auth":"none","summary":"Attackers can inject malicious scripts via crafted SSIDs in the wireless scan modal, potentially compromising user sessions in OpenWrt LuCI.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"luci","vendor":"openwrt"},{"product":"openwrt","vendor":"openwrt"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LuCI is the OpenWrt Configuration Interface. Versions prior to both 24.10.5 and 25.12.0, contain a stored XSS vulnerability in the wireless scan modal, where SSID values from scan results are rendered as raw HTML without any sanitization. The wireless.js file in the luci-mod-network package passes SSIDs via a template literal to dom.append(), which processes them through innerHTML, allowing an attacker to craft a malicious SSID containing arbitrary HTML/JavaScript. Exploitation requires the user to actively open the wireless scan modal (e.g., to connect to a Wi-Fi access point or survey nearby channels), and only affects OpenWrt versions newer than 23.05/22.03 up to the patched releases (24.10.6 and 25.12.1). The issue has been fixed in version LuCI 26.072.65753~068150b.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"LuCI luci-mod-network: Possible XSS attack in WiFi scan on Joining Wireless Client modal","id":"CVE-2026-32721","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"openwrt:openwrt","products":["openwrt:openwrt"],"type":"xss","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Memray-generated HTML reports vulnerable to Stored XSS via unescaped command-line metadata","id":"CVE-2026-32722"},"packages":[],"prev":{"headline":"Improper Access Control in github.com/ctfer-io/monitoring","id":"CVE-2026-32720"},"products":["luci","openwrt"],"published":"2026-03-19","related":[{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2019-12272","kev_date_added":null,"published":"2019-05-23"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2021-27821","kev_date_added":null,"published":"2021-05-25"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2023-24181","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2022-41435","kev_date_added":null,"published":"2022-11-03"},{"cvss_score":5.3,"headline":"Information disclosure in n/a","id":"CVE-2020-10871","kev_date_added":null,"published":"2020-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-25","vendors":["openwrt"]},"summary":"Attackers can inject malicious scripts via crafted SSIDs in the wireless scan modal, potentially compromising user sessions in OpenWrt LuCI.","url":"https://insights.sbomify.com/CVE-2026-32721/"}