# CVE-2026-32728: Parse Server has a stored XSS filter bypass via Content-Type MIME parameter and missing XML extension blocklist entries

> Attackers can bypass file extension filters to upload malicious files, leading to stored XSS and potential session or credential theft.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 19 Mar 2026
- **Also known as:** BIT-parse-2026-32728, GHSA-42ph-pf9q-cr72

## What is CVE-2026-32728?

CVE-2026-32728 is a high-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.15 and 8.6.41, an attacker who is allowed to upload files can bypass the file extension filter by appending a MIME parameter (e.g. `;charset=utf-8`) to the `Content-Type` header. This causes the extension validation to fail matching against the blocklist, allowing active content to be stored and served under the application's domain. In addition, certain XML-based file extensions that can render scripts in web browsers are not included in the default blocklist. This can lead to stored XSS attacks, compromising session tokens, user credentials, or other sensitive data accessible via the browser's local storage. The fix in versions 9.6.0-alpha.15 and 8.6.41 strips MIME parameters from the `Content-Type` header before validating the file extension against the blocklist. The default blocklist has also been extended to include additional XML-based extensions (`xsd`, `rng`, `rdf`, `rdf+xml`, `owl`, `mathml`, `mathml+xml`) that can render active content in web browsers. Note that the `fileUpload.fileExtensions` option is intended to be configured as an allowlist of file extensions that are valid for a specific application, not as a denylist. The default denylist is provided only as a basic default that covers most common problematic extensions. It is not intended to be an exhaustive list of all potentially dangerous extensions. Developers should not rely on the default value, as new extensions that can render active content in browsers might emerge in the future. As a workaround, configure the `fileUpload.fileExtensions` option to use an allowlist of only the file extensions that your application needs, rather than relying on the default blocklist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-32728?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.41 |
| `parse-server` | npm | All versions | 8.6.41 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.15 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.15 |
| `parse` | Bitnami | All versions | 8.6.41, 9.6.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-32728?

Upgrade parse-server to a fixed version for your release line: 8.6.41 or 9.6.0-alpha.15.

## Is CVE-2026-32728 being exploited?

There is no known exploitation of CVE-2026-32728 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32728 and fix it if it is affected.

What it is: CVE-2026-32728 is a high-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32728 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.41
- parse-server (npm): affected all versions; fixed in 8.6.41
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.15
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.15
- parse (Bitnami): affected all versions; fixed in 8.6.41, 9.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32728/ (Markdown: https://insights.sbomify.com/CVE-2026-32728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32728
- OSV: https://osv.dev/vulnerability/CVE-2026-32728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32728/
Summaries are generated and may contain mistakes; the official description above is the record.
