{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32730 exists.","fix":"Upgrade apostrophe to 4.28.0 or later.","what":"CVE-2026-32730 is a high-severity authentication bypass vulnerability in apostrophecms apostrophe, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32730 and fix it if it is affected.\n\nWhat it is: CVE-2026-32730 is a high-severity authentication bypass vulnerability in apostrophecms apostrophe, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32730 exists.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected all versions; fixed in 4.28.0\n- apostrophe (npm): affected all versions; fixed in 4.28.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32730/ (Markdown: https://insights.sbomify.com/CVE-2026-32730/index.md)","id":"CVE-2026-32730","markdown":"https://insights.sbomify.com/CVE-2026-32730/index.md","name":"CVE-2026-32730","record":{"aliases":["GHSA-v9xm-ffx2-7h35"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"ApostropheCMS","requires_auth":"none","summary":"Attackers can bypass multi-factor authentication in ApostropheCMS by exploiting a flawed MongoDB query in bearer token middleware, gaining unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apostrophecms","vendor":"apostrophecms"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"ApostropheCMS is an open-source content management framework. Prior to version 4.28.0, the bearer token authentication middleware in `@apostrophecms/express/index.js` (lines 386-389) contains an incorrect MongoDB query that allows incomplete login tokens — where the password was verified but TOTP/MFA requirements were NOT — to be used as fully authenticated bearer tokens. This completely bypasses multi-factor authentication for any ApostropheCMS deployment using `@apostrophecms/login-totp` or any custom `afterPasswordVerified` login requirement. Version 4.28.0 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware","id":"CVE-2026-32730","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction","id":"CVE-2026-32731"},"packages":[{"ecosystem":"npm","fixed":["4.28.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-v9xm-ffx2-7h35"},{"ecosystem":"npm","fixed":["4.28.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-v9xm-ffx2-7h35"}],"prev":{"headline":"Runtipi has a TOTP two-factor authentication bypass via unrestricted brute-force on `/api/auth/verify-totp`","id":"CVE-2026-32729"},"products":["apostrophe"],"published":"2026-03-18","related":[{"cvss_score":9.8,"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979","kev_date_added":null,"published":"2021-11-08"},{"cvss_score":8.7,"headline":"ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS","id":"CVE-2026-35569","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":6.1,"headline":"ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements","id":"CVE-2026-40186","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"Apostrophe - XSS","id":"CVE-2021-25978","kev_date_added":null,"published":"2021-11-07"},{"cvss_score":5.3,"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-19","vendors":["apostrophecms"]},"summary":"Attackers can bypass multi-factor authentication in ApostropheCMS by exploiting a flawed MongoDB query in bearer token middleware, gaining unauthorized access.","url":"https://insights.sbomify.com/CVE-2026-32730/"}