# CVE-2026-32730: ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware

> Attackers can bypass multi-factor authentication in ApostropheCMS by exploiting a flawed MongoDB query in bearer token middleware, gaining unauthorized access.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 19 Mar 2026
- **Also known as:** GHSA-v9xm-ffx2-7h35

## What is CVE-2026-32730?

CVE-2026-32730 is a high-severity authentication bypass vulnerability in apostrophecms apostrophe, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ApostropheCMS is an open-source content management framework. Prior to version 4.28.0, the bearer token authentication middleware in `@apostrophecms/express/index.js` (lines 386-389) contains an incorrect MongoDB query that allows incomplete login tokens — where the password was verified but TOTP/MFA requirements were NOT — to be used as fully authenticated bearer tokens. This completely bypasses multi-factor authentication for any ApostropheCMS deployment using `@apostrophecms/login-totp` or any custom `afterPasswordVerified` login requirement. Version 4.28.0 fixes the issue.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-32730?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.28.0 |
| `apostrophe` | npm | All versions | 4.28.0 |

Products: Apostrophecms Apostrophecms.

## How do I fix CVE-2026-32730?

Upgrade apostrophe to 4.28.0 or later.

## Is CVE-2026-32730 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32730 exists.

## Other vulnerabilities in apostrophecms apostrophe

- [CVE-2021-25979](https://insights.sbomify.com/CVE-2021-25979/): Apostrophe - Insufficient Session Expiration (critical 9.8)
- [CVE-2026-35569](https://insights.sbomify.com/CVE-2026-35569/): ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS (high 8.7)
- [CVE-2026-40186](https://insights.sbomify.com/CVE-2026-40186/): ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements (medium 6.1)
- [CVE-2026-33889](https://insights.sbomify.com/CVE-2026-33889/): ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context (medium 5.4)
- [CVE-2021-25978](https://insights.sbomify.com/CVE-2021-25978/): Apostrophe - XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32730 and fix it if it is affected.

What it is: CVE-2026-32730 is a high-severity authentication bypass vulnerability in apostrophecms apostrophe, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32730 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.28.0
- apostrophe (npm): affected all versions; fixed in 4.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32730/ (Markdown: https://insights.sbomify.com/CVE-2026-32730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32730
- OSV: https://osv.dev/vulnerability/CVE-2026-32730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32730/
Summaries are generated and may contain mistakes; the official description above is the record.
