{"answers":{"affected":"2 open source packages ship an affected version, including @leanprover/unicode-input-component.","exploited":"There is no known exploitation of CVE-2026-32732 in the wild and no public exploit code.","fix":"Upgrade @leanprover/unicode-input-component to 0.2.0 or later.","what":"CVE-2026-32732 is a cross-site scripting vulnerability in leanprover vscode-lean4, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-32732 and fix it if it is affected.\n\nWhat it is: CVE-2026-32732 is a cross-site scripting vulnerability in leanprover vscode-lean4, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-32732 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @leanprover/unicode-input-component (npm): affected all versions; fixed in 0.2.0\n- @leanprover/unicode-input-component (npm): affected all versions; fixed in 0.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32732/ (Markdown: https://insights.sbomify.com/CVE-2026-32732/index.md)","id":"CVE-2026-32732","markdown":"https://insights.sbomify.com/CVE-2026-32732/index.md","name":"CVE-2026-32732","record":{"aliases":["GHSA-6ggm-pwr9-r5h2"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"VS Code extension","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in the VS Code Lean 4 extension via unescaped HTML in the unicode input component.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"Lean 4 VS Code Extension is a Visual Studio Code extension for the Lean 4 proof assistant. Projects that use @leanprover/unicode-input-component are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML. The issue has been resolved in 0.2.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in @leanprover/unicode-input-component","id":"CVE-2026-32732","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Halloy has a file transfer path traveral vulnerability","id":"CVE-2026-32733"},"packages":[{"ecosystem":"npm","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"@leanprover/unicode-input-component","purl":null,"source":"GHSA-6ggm-pwr9-r5h2"},{"ecosystem":"npm","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"@leanprover/unicode-input-component","purl":"pkg:npm/%40leanprover/unicode-input-component","source":"GHSA-6ggm-pwr9-r5h2"}],"prev":{"headline":"ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction","id":"CVE-2026-32731"},"products":["vscode-lean4"],"published":"2026-03-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["leanprover"]},"summary":"Attackers can execute arbitrary scripts in the VS Code Lean 4 extension via unescaped HTML in the unicode input component.","url":"https://insights.sbomify.com/CVE-2026-32732/"}