CVE-2026-32742 Parse Server session creation endpoint allows overwriting server-generated session fields

Medium 4.3 Published Updated

Authenticated users can overwrite server-generated session fields to bypass expiration policies and predict tokens, enabling session hijacking.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32742?

CVE-2026-32742 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.17 and 8.6.42, an authenticated user can overwrite server-generated session fields (`sessionToken`, `expiresAt`, `createdWith`) when creating a session object via `POST /classes/_Session`. This allows bypassing the server's session expiration policy by setting an arbitrary far-future expiration date. It also allows setting a predictable session token value. Starting in version 9.6.0-alpha.17 and 8.6.42, the session creation endpoint filters out server-generated fields from user-supplied data, preventing them from being overwritten. As a workaround, add a `beforeSave` trigger on the `_Session` class to validate and reject or strip any user-supplied values for `sessionToken`, `expiresAt`, and `createdWith`.

Weakness: CWE-915

Which versions are affected by CVE-2026-32742?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.42
parse-server npmAll versions8.6.42
parse-server npmFrom 9.0.09.6.0-alpha.17
parse-server npmFrom 9.0.09.6.0-alpha.17
parse BitnamiAll versions8.6.42, 9.6.0

Products include Parseplatform Parse-Server.

How do I fix CVE-2026-32742?

Upgrade parse-server to a fixed version for your release line: 8.6.42 or 9.6.0-alpha.17.

Is CVE-2026-32742 being exploited?

There is no known exploitation of CVE-2026-32742 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2026-32742, GHSA-5v7g-9h8f-8pgg.

Is CVE-2026-32742 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free