# CVE-2026-32742: Parse Server session creation endpoint allows overwriting server-generated session fields

> Authenticated users can overwrite server-generated session fields to bypass expiration policies and predict tokens, enabling session hijacking.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** BIT-parse-2026-32742, GHSA-5v7g-9h8f-8pgg

## What is CVE-2026-32742?

CVE-2026-32742 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.17 and 8.6.42, an authenticated user can overwrite server-generated session fields (`sessionToken`, `expiresAt`, `createdWith`) when creating a session object via `POST /classes/_Session`. This allows bypassing the server's session expiration policy by setting an arbitrary far-future expiration date. It also allows setting a predictable session token value. Starting in version 9.6.0-alpha.17 and 8.6.42, the session creation endpoint filters out server-generated fields from user-supplied data, preventing them from being overwritten. As a workaround, add a `beforeSave` trigger on the `_Session` class to validate and reject or strip any user-supplied values for `sessionToken`, `expiresAt`, and `createdWith`.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2026-32742?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.42 |
| `parse-server` | npm | All versions | 8.6.42 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.17 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.17 |
| `parse` | Bitnami | All versions | 8.6.42, 9.6.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-32742?

Upgrade parse-server to a fixed version for your release line: 8.6.42 or 9.6.0-alpha.17.

## Is CVE-2026-32742 being exploited?

There is no known exploitation of CVE-2026-32742 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32742 and fix it if it is affected.

What it is: CVE-2026-32742 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32742 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.42
- parse-server (npm): affected all versions; fixed in 8.6.42
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.17
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.17
- parse (Bitnami): affected all versions; fixed in 8.6.42, 9.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32742/ (Markdown: https://insights.sbomify.com/CVE-2026-32742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32742
- OSV: https://osv.dev/vulnerability/CVE-2026-32742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32742/
Summaries are generated and may contain mistakes; the official description above is the record.
