CVE-2026-32770 Parse Server: LiveQuery subscription with invalid regular expression crashes server
Remote attackers can crash Parse Server by submitting invalid regular expressions in LiveQuery subscriptions, causing denial of service for all clients.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32770?
CVE-2026-32770 is a medium-severity denial of service vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.19 and 8.6.43, a remote attacker can crash the Parse Server by subscribing to a LiveQuery with an invalid regular expression pattern. The server process terminates when the invalid pattern reaches the regex engine during subscription matching, causing denial of service for all connected clients. The fix in 9.6.0-alpha.19 and 8.6.43 validates regular expression patterns at subscription time, rejecting invalid patterns before they are stored. Additionally, a defense-in-depth try-catch prevents any subscription matching error from crashing the server process. As a workaround, disable LiveQuery if it is not needed.
Weakness: CWE-248
Which versions are affected by CVE-2026-32770?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.43 |
parse-server npm | All versions | 8.6.43 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.19 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.19 |
parse Bitnami | All versions | 8.6.43, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-32770?
Upgrade parse-server to a fixed version for your release line: 8.6.43 or 9.6.0-alpha.19.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-32770 being exploited?
There is no known exploitation of CVE-2026-32770 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-32770, GHSA-827p-g5x5-h86c.