CVE-2026-32773 Apache Spark: XSS Vulnerability in Spark Web 3.5.4
Attackers with job submission rights can inject scripts into the Spark History Server, potentially escalating privileges in the victim's browser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-32773?
CVE-2026-32773 is a medium-severity cross-site scripting vulnerability in Apache Spark, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later.
This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page.
Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
Weakness: CWE-80
Which versions are affected by CVE-2026-32773?
8 open source packages ship an affected version, including org.apache.spark:spark-core_2.12, spark and org.apache.spark:spark-core_2.13. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.spark:spark-core_2.12 Maven | From 3.0.0 | 3.5.8 |
org.apache.spark:spark-core_2.12 Maven | From 3.0.0 | 3.5.8 |
spark Bitnami | From 3.0.0 | 3.5.8 |
org.apache.spark:spark-core_2.13 Maven | From 3.0.0 | 3.5.8 |
org.apache.spark:spark-core_2.13 Maven | From 3.0.0 | 3.5.8 |
pyspark PyPI | From 3.0.0 | 3.5.8 |
2 more packages
pyspark PyPI | From 3.0.0 | 3.5.8 |
pyspark PyPI | From 3.0.0 | 3.5.8 |
Products include Apache Spark.
How do I fix CVE-2026-32773?
Upgrade org.apache.spark:spark-core_2.12 to 3.5.8 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-32773 being exploited?
There is no known exploitation of CVE-2026-32773 in the wild and no public exploit code.
Other vulnerabilities in Apache Spark
Sources
Also known as BIT-spark-2026-32773, GHSA-9437-39hj-3c93, MINI-c695-7r4p-j8mq, MINI-h6vp-4c5q-qj39, MINI-m3j8-w53h-jp2j, PYSEC-2026-3966.