# CVE-2026-32773: Apache Spark: XSS Vulnerability in Spark Web 3.5.4

> Attackers with job submission rights can inject scripts into the Spark History Server, potentially escalating privileges in the victim's browser.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2026
- **Updated:** 2 Sep 2026
- **Also known as:** BIT-spark-2026-32773, GHSA-9437-39hj-3c93, MINI-c695-7r4p-j8mq, MINI-h6vp-4c5q-qj39, MINI-m3j8-w53h-jp2j, PYSEC-2026-3966

## What is CVE-2026-32773?

CVE-2026-32773 is a medium-severity cross-site scripting vulnerability in Apache Spark, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later.

This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page.

Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-32773?

8 open source packages ship an affected version, including org.apache.spark:spark-core_2.12, spark and org.apache.spark:spark-core_2.13. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core_2.12` | Maven | From 3.0.0 | 3.5.8 |
| `org.apache.spark:spark-core_2.12` | Maven | From 3.0.0 | 3.5.8 |
| `spark` | Bitnami | From 3.0.0 | 3.5.8 |
| `org.apache.spark:spark-core_2.13` | Maven | From 3.0.0 | 3.5.8 |
| `org.apache.spark:spark-core_2.13` | Maven | From 3.0.0 | 3.5.8 |
| `pyspark` | PyPI | From 3.0.0 | 3.5.8 |
| `pyspark` | PyPI | From 3.0.0 | 3.5.8 |
| `pyspark` | PyPI | From 3.0.0 | 3.5.8 |

Products: Apache Spark.

## How do I fix CVE-2026-32773?

Upgrade org.apache.spark:spark-core_2.12 to 3.5.8 or later.

## Is CVE-2026-32773 being exploited?

There is no known exploitation of CVE-2026-32773 in the wild and no public exploit code.

## Other vulnerabilities in Apache Spark

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32773 and fix it if it is affected.

What it is: CVE-2026-32773 is a medium-severity cross-site scripting vulnerability in Apache Spark, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32773 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core_2.12 (Maven): affected from 3.0.0; fixed in 3.5.8
- org.apache.spark:spark-core_2.12 (Maven): affected from 3.0.0; fixed in 3.5.8
- spark (Bitnami): affected from 3.0.0; fixed in 3.5.8
- org.apache.spark:spark-core_2.13 (Maven): affected from 3.0.0; fixed in 3.5.8
- org.apache.spark:spark-core_2.13 (Maven): affected from 3.0.0; fixed in 3.5.8
- pyspark (PyPI): affected from 3.0.0; fixed in 3.5.8
- pyspark (PyPI): affected from 3.0.0; fixed in 3.5.8
- pyspark (PyPI): affected from 3.0.0; fixed in 3.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32773/ (Markdown: https://insights.sbomify.com/CVE-2026-32773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32773
- OSV: https://osv.dev/vulnerability/CVE-2026-32773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32773/
Summaries are generated and may contain mistakes; the official description above is the record.
