{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32794 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 1.12.0 or later.","what":"CVE-2026-32794 is a medium-severity vulnerability in Apache Airflow Provider for Databricks, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32794 and fix it if it is affected.\n\nWhat it is: CVE-2026-32794 is a medium-severity vulnerability in Apache Airflow Provider for Databricks, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32794 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected from 1.10.0; fixed in 1.12.0\n- apache-airflow (PyPI): affected from 1.10.0; fixed in 1.12.0\n- apache-airflow (PyPI): affected from 1.10.0; fixed in 1.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32794/ (Markdown: https://insights.sbomify.com/CVE-2026-32794/index.md)","id":"CVE-2026-32794","markdown":"https://insights.sbomify.com/CVE-2026-32794/index.md","name":"CVE-2026-32794","record":{"aliases":["GHSA-wrpj-755p-x363","PYSEC-2026-2357"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Airflow Databricks provider","requires_auth":"none","summary":"Attackers can intercept traffic and steal credentials via man-in-the-middle attacks due to disabled TLS certificate verification in the Databricks provider.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow_providers_databricks","vendor":"apache"}],"cvss":{"score":4.8,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice.\n\nThis issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0.\n\nUsers are recommended to upgrade to version 1.12.0, which fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-03-24","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-03-24T01:58:19Z","kind":"github_poc","ref":"https://github.com/SnailSploit/CVE-2026-32794","stars":1,"title":"CVE-2026-32794: TLS Certificate Verification Bypass in Apache Airflow Databricks Provider"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache Airflow Provider for Databricks: TLS Certificate Verification Disabled in Databricks Provider K8s Token Exchange","id":"CVE-2026-32794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Privilege escalation in PowerPath","id":"CVE-2026-32802"},"packages":[{"ecosystem":"PyPI","fixed":["1.12.0"],"introduced":["1.10.0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-wrpj-755p-x363"},{"ecosystem":"PyPI","fixed":["1.12.0"],"introduced":["1.10.0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-wrpj-755p-x363"},{"ecosystem":"PyPI","fixed":["1.12.0"],"introduced":["1.10.0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2026-2357"}],"prev":{"headline":"Packet of death with DNSCrypt","id":"CVE-2026-32792"},"products":["Apache Airflow Provider for Databricks"],"published":"2026-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-31","vendors":["Apache Software Foundation"]},"summary":"Attackers can intercept traffic and steal credentials via man-in-the-middle attacks due to disabled TLS certificate verification in the Databricks provider.","url":"https://insights.sbomify.com/CVE-2026-32794/"}