# CVE-2026-32811: Heimdall: Path received via Envoy gRPC corrupted when containing query string

> Attackers can bypass access control rules in Heimdall by exploiting URL encoding issues, potentially gaining unauthorized access if insecure defaults are enabled.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 21 Mar 2026
- **Also known as:** GHSA-r8x2-fhmf-6mxp, GO-2026-4742

## What is CVE-2026-32811?

CVE-2026-32811 is a high-severity authentication bypass vulnerability in dadrus heimdall, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Heimdall is a cloud native Identity Aware Proxy and Access Control Decision service. When using Heimdall in envoy gRPC decision API mode with versions 0.7.0-alpha through 0.17.10, wrong encoding of the query URL string allows rules with non-wildcard path expressions to be bypassed. Envoy splits the requested URL into parts, and sends the parts individually to Heimdall. Although query and path are present in the API, the query field is documented to be always empty and the URL query is included in the path field. The implementation uses go's url library to reconstruct the url which automatically encodes special characters in the path. As a consequence, a parameter like /mypath?foo=bar to Path is escaped into /mypath%3Ffoo=bar. Subsequently, a rule matching /mypath no longer matches and is bypassed. The issue can only lead to unintended access if Heimdall is configured with an "allow all" default rule. Since v0.16.0, Heimdall enforces secure defaults and refuses to start with such a configuration unless this enforcement is explicitly disabled, e.g. via --insecure-skip-secure-default-rule-enforcement or the broader --insecure flag. This issue has been fixed in version 0.17.11.

Weakness: CWE-863 (Incorrect Authorization), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-32811?

3 open source packages ship an affected version, including github.com/dadrus/heimdall. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dadrus/heimdall` | Go | From 0.7.0-alpha | 0.17.11 |
| `github.com/dadrus/heimdall` | Go | From 0.7.0-alpha | 0.17.11 |
| `github.com/dadrus/heimdall` | Go | From 0.7.0-alpha | 0.17.11 |

Products: Dadrus Heimdall.

## How do I fix CVE-2026-32811?

Upgrade github.com/dadrus/heimdall to 0.17.11 or later.

## Is CVE-2026-32811 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32811 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32811 and fix it if it is affected.

What it is: CVE-2026-32811 is a high-severity authentication bypass vulnerability in dadrus heimdall, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32811 exists.

Affected packages and fixed versions:
- github.com/dadrus/heimdall (Go): affected from 0.7.0-alpha; fixed in 0.17.11
- github.com/dadrus/heimdall (Go): affected from 0.7.0-alpha; fixed in 0.17.11
- github.com/dadrus/heimdall (Go): affected from 0.7.0-alpha; fixed in 0.17.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32811/ (Markdown: https://insights.sbomify.com/CVE-2026-32811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32811
- OSV: https://osv.dev/vulnerability/CVE-2026-32811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32811/
Summaries are generated and may contain mistakes; the official description above is the record.
