# CVE-2026-32813: Admidio: Second-Order SQL Injection via List Configuration (lsc_special_field, lsc_sort, lsc_filter)

> Authenticated attackers can exploit second-order SQL injection in Admidio's list configuration to read, modify, or delete database data.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-3x67-4c2c-w45m

## What is CVE-2026-32813?

CVE-2026-32813 is a high-severity SQL injection vulnerability in admidio, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Admidio is an open-source user management solution. Versions 5.0.6 and below are vulnerable to arbitrary SQL Injection through the MyList configuration feature. The MyList configuration feature lets authenticated users define custom list column layouts, storing user-supplied column names, sort directions, and filter conditions in the adm_list_columns table via prepared statements. However, these stored values are later read back and interpolated directly into dynamically constructed SQL queries without sanitization or parameterization, creating a classic second-order SQL injection vulnerability (safe write, unsafe read). An attacker can exploit this to inject arbitrary SQL, potentially reading, modifying, or deleting any data in the database and achieving full database compromise. This issue has been fixed in version 5.0.7.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-32813?

2 open source packages ship an affected version, including admidio/admidio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | All versions | 5.0.7 |
| `admidio/admidio` | Packagist | All versions | 5.0.7 |

Products: Admidio Admidio.

## How do I fix CVE-2026-32813?

Upgrade admidio/admidio to 5.0.7 or later.

## Is CVE-2026-32813 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32813 exists.

## Other vulnerabilities in admidio

- [CVE-2024-37906](https://insights.sbomify.com/CVE-2024-37906/): Admidio has Blind SQL Injection in ecard_send.php (critical 10.0)
- [CVE-2021-32630](https://insights.sbomify.com/CVE-2021-32630/): Various (critical 9.6)
- [CVE-2026-32817](https://insights.sbomify.com/CVE-2026-32817/): Admidio is Missing Authorization and CSRF Protection on Document and Folder Deletion (critical 9.1)
- [CVE-2024-38529](https://insights.sbomify.com/CVE-2024-38529/): Admidio Vulnerable to RCE via Arbitrary File Upload in Message Attachment (critical 9.1)
- [CVE-2026-32756](https://insights.sbomify.com/CVE-2026-32756/): Admidio: Unrestricted File Upload via CSRF Token Validation Bypass in Documents & Files Module (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32813 and fix it if it is affected.

What it is: CVE-2026-32813 is a high-severity SQL injection vulnerability in admidio, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32813 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.7
- admidio/admidio (Packagist): affected all versions; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32813/ (Markdown: https://insights.sbomify.com/CVE-2026-32813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32813
- OSV: https://osv.dev/vulnerability/CVE-2026-32813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32813/
Summaries are generated and may contain mistakes; the official description above is the record.
