CVE-2026-32816 Admidio has Missing CSRF Validation on Role Delete, Activate, and Deactivate Actions

Medium 5.7 Published Updated

Attackers can trick authorized users into permanently deleting or modifying organizational roles via forged requests, disrupting access controls and data integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-32816?

CVE-2026-32816 is a medium-severity vulnerability in admidio, published on 19 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Admidio is an open-source user management solution. In versions 5.0.0 through 5.0.6, the delete, activate, and deactivate modes in modules/groups-roles/groups_roles.php perform destructive state changes on organizational roles but never validate an anti-CSRF token. The client-side UI passes a CSRF token to callUrlHideElement(), which includes it in the POST body, but the server-side handlers ignore $_POST["adm_csrf_token"] entirely for these three modes. An attacker who can discover a role UUID (visible in the public cards view when the module is publicly accessible) can embed a forged POST form on any external page and trick any user with the rol_assign_roles right into deleting or toggling roles for the organization. Role deletion is permanent and cascades to all memberships, event associations, and rights data. If exploited, an attacker can trick any user with delegated role-assignment rights into permanently deleting roles, mass-revoking all associated memberships and access to events, documents, and mailing lists, or silently activating or deactivating entire groups, with target role UUIDs trivially harvested from the unauthenticated public cards view and no undo path short of a database restore. This issue has been fixed in version 5.0.7.

Weakness: CWE-352

Which versions are affected by CVE-2026-32816?

2 open source packages ship an affected version, including admidio/admidio. It affects 1 product.

PackageAffectedFixed in
admidio/admidio PackagistFrom 5.0.05.0.7
admidio/admidio PackagistFrom 5.0.05.0.7

Products include Admidio Admidio.

How do I fix CVE-2026-32816?

Upgrade admidio/admidio to 5.0.7 or later.

Is CVE-2026-32816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32816 exists.

Sources

Also known as GHSA-wwg8-6ffr-h4q2.

Is CVE-2026-32816 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free