# CVE-2026-32816: Admidio has Missing CSRF Validation on Role Delete, Activate, and Deactivate Actions

> Attackers can trick authorized users into permanently deleting or modifying organizational roles via forged requests, disrupting access controls and data integrity.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-wwg8-6ffr-h4q2

## What is CVE-2026-32816?

CVE-2026-32816 is a medium-severity vulnerability in admidio, published on 19 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Admidio is an open-source user management solution. In versions 5.0.0 through 5.0.6, the delete, activate, and deactivate modes in modules/groups-roles/groups_roles.php perform destructive state changes on organizational roles but never validate an anti-CSRF token. The client-side UI passes a CSRF token to callUrlHideElement(), which includes it in the POST body, but the server-side handlers ignore $_POST["adm_csrf_token"] entirely for these three modes. An attacker who can discover a role UUID (visible in the public cards view when the module is publicly accessible) can embed a forged POST form on any external page and trick any user with the rol_assign_roles right into deleting or toggling roles for the organization. Role deletion is permanent and cascades to all memberships, event associations, and rights data. If exploited, an attacker can trick any user with delegated role-assignment rights into permanently deleting roles, mass-revoking all associated memberships and access to events, documents, and mailing lists, or silently activating or deactivating entire groups, with target role UUIDs trivially harvested from the unauthenticated public cards view and no undo path short of a database restore. This issue has been fixed in version 5.0.7.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-32816?

2 open source packages ship an affected version, including admidio/admidio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | From 5.0.0 | 5.0.7 |
| `admidio/admidio` | Packagist | From 5.0.0 | 5.0.7 |

Products: Admidio Admidio.

## How do I fix CVE-2026-32816?

Upgrade admidio/admidio to 5.0.7 or later.

## Is CVE-2026-32816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32816 exists.

## Other vulnerabilities in admidio

- [CVE-2024-37906](https://insights.sbomify.com/CVE-2024-37906/): Admidio has Blind SQL Injection in ecard_send.php (critical 10.0)
- [CVE-2021-32630](https://insights.sbomify.com/CVE-2021-32630/): Various (critical 9.6)
- [CVE-2026-32817](https://insights.sbomify.com/CVE-2026-32817/): Admidio is Missing Authorization and CSRF Protection on Document and Folder Deletion (critical 9.1)
- [CVE-2024-38529](https://insights.sbomify.com/CVE-2024-38529/): Admidio Vulnerable to RCE via Arbitrary File Upload in Message Attachment (critical 9.1)
- [CVE-2026-32756](https://insights.sbomify.com/CVE-2026-32756/): Admidio: Unrestricted File Upload via CSRF Token Validation Bypass in Documents & Files Module (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32816 and fix it if it is affected.

What it is: CVE-2026-32816 is a medium-severity vulnerability in admidio, published on 19 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32816 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected from 5.0.0; fixed in 5.0.7
- admidio/admidio (Packagist): affected from 5.0.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32816/ (Markdown: https://insights.sbomify.com/CVE-2026-32816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32816
- OSV: https://osv.dev/vulnerability/CVE-2026-32816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32816/
Summaries are generated and may contain mistakes; the official description above is the record.
