# CVE-2026-32817: Admidio is Missing Authorization and CSRF Protection on Document and Folder Deletion

> Attackers can delete documents and folders without proper authorization or CSRF protection, potentially destroying data in Admidio.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-rmpj-3x5m-9m5f

## What is CVE-2026-32817?

CVE-2026-32817 is a critical missing authorization vulnerability in admidio, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Admidio is an open-source user management solution. In versions 5.0.0 through 5.0.6, the documents and files module does not verify whether the current user has permission to delete folders or files. The folder_delete and file_delete action handlers in modules/documents-files.php only perform a VIEW authorization check (getFolderForDownload / getFileForDownload) before calling delete(), and they never validate a CSRF token. Because the target UUIDs are read from $_GET, deletion can be triggered by a plain HTTP GET request. When the module is in public mode (documents_files_module_enabled = 1) and a folder is marked public (fol_public = true), an unauthenticated attacker can permanently destroy the entire document library. Even when the module requires login, any user with view-only access can delete content they are only permitted to read. This issue has been fixed in version 5.0.7.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-32817?

2 open source packages ship an affected version, including admidio/admidio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admidio/admidio` | Packagist | From 5.0.0 | 5.0.7 |
| `admidio/admidio` | Packagist | From 5.0.0 | 5.0.7 |

Products: Admidio Admidio.

## How do I fix CVE-2026-32817?

Upgrade admidio/admidio to 5.0.7 or later.

## Is CVE-2026-32817 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32817 exists.

## Other vulnerabilities in admidio

- [CVE-2024-37906](https://insights.sbomify.com/CVE-2024-37906/): Admidio has Blind SQL Injection in ecard_send.php (critical 10.0)
- [CVE-2021-32630](https://insights.sbomify.com/CVE-2021-32630/): Various (critical 9.6)
- [CVE-2024-38529](https://insights.sbomify.com/CVE-2024-38529/): Admidio Vulnerable to RCE via Arbitrary File Upload in Message Attachment (critical 9.1)
- [CVE-2026-32756](https://insights.sbomify.com/CVE-2026-32756/): Admidio: Unrestricted File Upload via CSRF Token Validation Bypass in Documents & Files Module (high 8.8)
- [CVE-2021-43810](https://insights.sbomify.com/CVE-2021-43810/): Cross-site Scripting (XSS) when redirect an url (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32817 and fix it if it is affected.

What it is: CVE-2026-32817 is a critical missing authorization vulnerability in admidio, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32817 exists.

Affected packages and fixed versions:
- admidio/admidio (Packagist): affected from 5.0.0; fixed in 5.0.7
- admidio/admidio (Packagist): affected from 5.0.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32817/ (Markdown: https://insights.sbomify.com/CVE-2026-32817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32817
- OSV: https://osv.dev/vulnerability/CVE-2026-32817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32817/
Summaries are generated and may contain mistakes; the official description above is the record.
