# CVE-2026-32825: dataCycle No Brute-Force Protection On Web And API Login Endpoints

> Attackers can perform unlimited brute-force attacks on login endpoints due to missing rate limiting and lockout mechanisms, potentially leading to account takeover.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026

## What is CVE-2026-32825?

CVE-2026-32825 is a high-severity vulnerability in datacycle-engine dataCycle-CORE, published on 20 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

dataCycle is a data management system for centrally storing, managing, searching, finding, and distributing data. In dataCycle-CORE, the module handling core processing and framework rules, before and including version 25.07.3, the application accepts unlimited password guesses against both the browser login flow and the JSON login endpoint. The source code enables Devise's `:lockable` module on the user model but explicitly disables both lock and unlock strategies, and no request throttling or rate-limiting layer was identified in the Rails code. This creates a direct online password-guessing risk:
- valid user accounts can be attacked continuously without temporary lockout
- the same weakness is reachable through both `/users/sign_in` and `/api/v4/auth/login`
- successful guessing yields a normal session cookie in the HTML flow or a fresh JWT in the API flow
- the API endpoint is especially attractive for automation because it requires no CSRF token

This has been patched in version 26.06.08.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-32825?


## How do I fix CVE-2026-32825?

No fix has been published for CVE-2026-32825 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32825 being exploited?

There is no known exploitation of CVE-2026-32825 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32825 and fix it if it is affected.

What it is: CVE-2026-32825 is a high-severity vulnerability in datacycle-engine dataCycle-CORE, published on 20 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32825 in the wild and no public exploit code.

Affected product: datacycle-engine dataCycle-CORE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32825/ (Markdown: https://insights.sbomify.com/CVE-2026-32825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32825
- OSV: https://osv.dev/vulnerability/CVE-2026-32825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32825/
Summaries are generated and may contain mistakes; the official description above is the record.
