# CVE-2026-32828: Kargo: SSRF in Promotion http/http-download Steps Enables Internal Network Access and Data Exfiltration

> Authenticated attackers can exploit SSRF in Kargo promotion steps to access internal networks and exfiltrate sensitive cloud metadata credentials.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-j94x-8wcp-x7hm, GO-2026-4717

## What is CVE-2026-32828?

CVE-2026-32828 is a medium-severity server-side request forgery vulnerability in akuity kargo, published on 20 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kargo manages and automates the promotion of software artifacts. In versions 1.4.0 through 1.6.3, 1.7.0-rc.1 through 1.7.8, 1.8.0-rc.1 through 1.8.11, and 1.9.0-rc.1 through 1.9.4, the http and http-download promotion steps allow Server-Side Request Forgery (SSRF) against link-local addresses, most critically the cloud instance metadata endpoint (169.254.169.254), enabling exfiltration of sensitive data such as IAM credentials. These steps provide full control over request headers and methods, rendering cloud provider header-based SSRF mitigations ineffective. An authenticated attacker with permissions to create/update Stages or craft Promotion resources can exploit this by submitting a malicious Promotion manifest, with response data retrievable via Promotion status fields, Git repositories, or a second http step. This issue has been fixed in versions 1.6.4, 1.7.9, 1.8.12 and 1.9.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-32828?

9 open source packages ship an affected version, including github.com/akuity/kargo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/akuity/kargo` | Go | From 1.4.0 | 1.6.4, 1.7.9, 1.8.12, 1.9.5 |
| `github.com/akuity/kargo` | Go | From 1.4.0 | 1.6.4 |
| `github.com/akuity/kargo` | Go | From 1.4.0 | 1.6.4 |
| `github.com/akuity/kargo` | Go | From 1.7.0-rc.1 | 1.7.9 |
| `github.com/akuity/kargo` | Go | From 1.7.0-rc.1 | 1.7.9 |
| `github.com/akuity/kargo` | Go | From 1.8.0-rc.1 | 1.8.12 |
| `github.com/akuity/kargo` | Go | From 1.8.0-rc.1 | 1.8.12 |
| `github.com/akuity/kargo` | Go | From 1.9.0-rc.1 | 1.9.5 |
| `github.com/akuity/kargo` | Go | From 1.9.0-rc.1 | 1.9.5 |

Products: Akuity Kargo.

## How do I fix CVE-2026-32828?

Upgrade github.com/akuity/kargo to a fixed version for your release line: 1.6.4, 1.7.9, 1.8.12 or 1.9.5.

## Is CVE-2026-32828 being exploited?

There is no known exploitation of CVE-2026-32828 in the wild and no public exploit code.

## Other vulnerabilities in akuity kargo

- [CVE-2026-27112](https://insights.sbomify.com/CVE-2026-27112/): Kargo has an Authorization Bypass Vulnerability in Batch Resource Creation API Endpoints (critical 9.4)
- [CVE-2026-24748](https://insights.sbomify.com/CVE-2026-24748/): Kargo's `GetConfig()` and `RefreshResource()` API endpoints allow unauthenticated access (medium 6.9)
- [CVE-2026-27111](https://insights.sbomify.com/CVE-2026-27111/): Kargo has Missing Authorization Vulnerabilities in Approval & Promotion REST API Endpoints (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32828 and fix it if it is affected.

What it is: CVE-2026-32828 is a medium-severity server-side request forgery vulnerability in akuity kargo, published on 20 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32828 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/akuity/kargo (Go): affected from 1.4.0; fixed in 1.6.4, 1.7.9, 1.8.12, 1.9.5
- github.com/akuity/kargo (Go): affected from 1.4.0; fixed in 1.6.4
- github.com/akuity/kargo (Go): affected from 1.4.0; fixed in 1.6.4
- github.com/akuity/kargo (Go): affected from 1.7.0-rc.1; fixed in 1.7.9
- github.com/akuity/kargo (Go): affected from 1.7.0-rc.1; fixed in 1.7.9
- github.com/akuity/kargo (Go): affected from 1.8.0-rc.1; fixed in 1.8.12
- github.com/akuity/kargo (Go): affected from 1.8.0-rc.1; fixed in 1.8.12
- github.com/akuity/kargo (Go): affected from 1.9.0-rc.1; fixed in 1.9.5
- github.com/akuity/kargo (Go): affected from 1.9.0-rc.1; fixed in 1.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32828/ (Markdown: https://insights.sbomify.com/CVE-2026-32828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32828
- OSV: https://osv.dev/vulnerability/CVE-2026-32828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32828/
Summaries are generated and may contain mistakes; the official description above is the record.
