CVE-2026-32829 lz4_flex: Decompression can leak information from uninitialized memory or reused output buffer

High 8.2 Published Updated

Attackers can leak sensitive data from uninitialized memory or previous buffers by providing malformed LZ4 input to affected decompression functions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32829?

CVE-2026-32829 is a high-severity vulnerability in PSeitz lz4_flex, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

Weakness: CWE-823, CWE-201

Which versions are affected by CVE-2026-32829?

5 open source packages ship an affected version, including lz4_flex. It affects 1 product.

PackageAffectedFixed in
lz4_flex crates.ioAll versions0.11.6
lz4_flex crates.ioAll versions0.11.6
lz4_flex crates.ioFrom 0.0.0-00.11.6, 0.12.1
lz4_flex crates.ioFrom 0.12.00.12.1
lz4_flex crates.ioFrom 0.12.00.12.1

Products include Pseitz Lz4 Flex.

How do I fix CVE-2026-32829?

Upgrade lz4_flex to a fixed version for your release line: 0.11.6 or 0.12.1.

Is CVE-2026-32829 being exploited?

There is no known exploitation of CVE-2026-32829 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-32829, GHSA-vvp9-7p8x-rfvv, RUSTSEC-2026-0041, UBUNTU-CVE-2026-32829.

Is CVE-2026-32829 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free