# CVE-2026-32829: lz4_flex: Decompression can leak information from uninitialized memory or reused output buffer

> Attackers can leak sensitive data from uninitialized memory or previous buffers by providing malformed LZ4 input to affected decompression functions.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 17 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-32829, GHSA-vvp9-7p8x-rfvv, RUSTSEC-2026-0041, UBUNTU-CVE-2026-32829

## What is CVE-2026-32829?

CVE-2026-32829 is a high-severity vulnerability in PSeitz lz4_flex, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0,  decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

Weakness: CWE-823 (Use of Out-of-range Pointer Offset), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-32829?

5 open source packages ship an affected version, including lz4_flex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lz4_flex` | crates.io | All versions | 0.11.6 |
| `lz4_flex` | crates.io | All versions | 0.11.6 |
| `lz4_flex` | crates.io | From 0.0.0-0 | 0.11.6, 0.12.1 |
| `lz4_flex` | crates.io | From 0.12.0 | 0.12.1 |
| `lz4_flex` | crates.io | From 0.12.0 | 0.12.1 |

Products: Pseitz Lz4 Flex.

## How do I fix CVE-2026-32829?

Upgrade lz4_flex to a fixed version for your release line: 0.11.6 or 0.12.1.

## Is CVE-2026-32829 being exploited?

There is no known exploitation of CVE-2026-32829 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32829 and fix it if it is affected.

What it is: CVE-2026-32829 is a high-severity vulnerability in PSeitz lz4_flex, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32829 in the wild and no public exploit code.

Affected packages and fixed versions:
- lz4_flex (crates.io): affected all versions; fixed in 0.11.6
- lz4_flex (crates.io): affected all versions; fixed in 0.11.6
- lz4_flex (crates.io): affected from 0.0.0-0; fixed in 0.11.6, 0.12.1
- lz4_flex (crates.io): affected from 0.12.0; fixed in 0.12.1
- lz4_flex (crates.io): affected from 0.12.0; fixed in 0.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32829/ (Markdown: https://insights.sbomify.com/CVE-2026-32829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32829
- OSV: https://osv.dev/vulnerability/CVE-2026-32829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32829/
Summaries are generated and may contain mistakes; the official description above is the record.
