CVE-2026-32870 Kirby has XML injection in its XML creator toolkit
Attackers can inject malicious XML structures via CDATA bypass in Kirby CMS, potentially leading to code execution or data exposure if XML generation is used.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32870?
CVE-2026-32870 is a medium-severity vulnerability in getkirby kirby, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is an open-source content management system. Kirby's `Xml::value()` method has special handling for `<![CDATA[ ]]>` blocks. If the input value is already valid `CDATA`, it is not escaped a second time but allowed to pass through. However, prior to versions 4.9.0 and 5.4.0, it was possible to trick this check into allowing values that only contained a valid `CDATA` block but also contained other structured data outside of the `CDATA` block. This structured data would then also be allowed to pass through, circumventing the value protection. The `Xml::value()` method is used in `Xml::tag()`, `Xml::create()` and in the `Xml` data handler (e.g. `Data::encode($string, 'xml')`). Both the vulnerable methods and the data handler are not used in the Kirby core. However they may be used in site or plugin code, e.g. to create XML strings from input data. If those generated files are passed to another implementation that assigns specific meaning to the XML schema, manipulation of this system's behavior is possible. Kirby sites that don't use XML generation in site or plugin code are not affected. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. In all of the mentioned releases, Kirby has added additional checks that only allow unchanged `CDATA` passthrough if the entire string is made up of valid `CDATA` blocks and no structured data. This protects all uses of the method against the described vulnerability.
Weakness: CWE-91
Which versions are affected by CVE-2026-32870?
4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
Products include Getkirby Kirby.
How do I fix CVE-2026-32870?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.
Is CVE-2026-32870 being exploited?
There is no known exploitation of CVE-2026-32870 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-9wfj-c55w-j9qr.