{"answers":{"affected":"4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32870 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.","what":"CVE-2026-32870 is a medium-severity vulnerability in getkirby kirby, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32870 and fix it if it is affected.\n\nWhat it is: CVE-2026-32870 is a medium-severity vulnerability in getkirby kirby, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32870 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.0\n- getkirby/cms (Packagist): affected all versions; fixed in 4.9.0\n- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.0\n- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32870/ (Markdown: https://insights.sbomify.com/CVE-2026-32870/index.md)","id":"CVE-2026-32870","markdown":"https://insights.sbomify.com/CVE-2026-32870/index.md","name":"CVE-2026-32870","record":{"aliases":["GHSA-9wfj-c55w-j9qr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Kirby CMS","requires_auth":"none","summary":"Attackers can inject malicious XML structures via CDATA bypass in Kirby CMS, potentially leading to code execution or data exposure if XML generation is used.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kirby","vendor":"getkirby"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-91","name":"XML Injection"}],"description":"Kirby is an open-source content management system. Kirby's `Xml::value()` method has special handling for `\u003c![CDATA[ ]]\u003e` blocks. If the input value is already valid `CDATA`, it is not escaped a second time but allowed to pass through. However, prior to versions 4.9.0 and 5.4.0, it was possible to trick this check into allowing values that only contained a valid `CDATA` block but also contained other structured data outside of the `CDATA` block. This structured data would then also be allowed to pass through, circumventing the value protection. The `Xml::value()` method is used in `Xml::tag()`, `Xml::create()` and in the `Xml` data handler (e.g. `Data::encode($string, 'xml')`). Both the vulnerable methods and the data handler are not used in the Kirby core. However they may be used in site or plugin code, e.g. to create XML strings from input data. If those generated files are passed to another implementation that assigns specific meaning to the XML schema, manipulation of this system's behavior is possible. Kirby sites that don't use XML generation in site or plugin code are not affected. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. In all of the mentioned releases, Kirby has added additional checks that only allow unchanged `CDATA` passthrough if the entire string is made up of valid `CDATA` blocks and no structured data. This protects all uses of the method against the described vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kirby has XML injection in its XML creator toolkit","id":"CVE-2026-32870","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"FastMCP OpenAPI Provider has an SSRF \u0026 Path Traversal Vulnerability","id":"CVE-2026-32871"},"packages":[{"ecosystem":"Packagist","fixed":["4.9.0"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-9wfj-c55w-j9qr"},{"ecosystem":"Packagist","fixed":["4.9.0"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-9wfj-c55w-j9qr"},{"ecosystem":"Packagist","fixed":["5.4.0"],"introduced":["5.0.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-9wfj-c55w-j9qr"},{"ecosystem":"Packagist","fixed":["5.4.0"],"introduced":["5.0.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-9wfj-c55w-j9qr"}],"prev":{"headline":"OPEXUS eComplaint and eCASE XSS via Name of Organization field","id":"CVE-2026-32869"},"products":["kirby"],"published":"2026-04-24","related":[{"cvss_score":8.8,"headline":"Kirby vulnerable to unrestricted file upload of user avatar images","id":"CVE-2024-26483","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.1,"headline":"Insufficient permission checks in the language settings in Kirby CMS","id":"CVE-2024-41964","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":7.6,"headline":"Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering","id":"CVE-2026-34587","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.6,"headline":"Cross-site scripting (XSS) from unsanitized uploaded SVG files","id":"CVE-2021-29460","kev_date_added":null,"published":"2021-04-27"},{"cvss_score":7.3,"headline":"Kirby vulnerable to Insufficient Session Expiration after a password change","id":"CVE-2023-38489","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from writer field content in the site frontend","id":"CVE-2021-41252","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from image block content in the site frontend","id":"CVE-2021-41258","kev_date_added":null,"published":"2021-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-24","vendors":["getkirby"]},"summary":"Attackers can inject malicious XML structures via CDATA bypass in Kirby CMS, potentially leading to code execution or data exposure if XML generation is used.","url":"https://insights.sbomify.com/CVE-2026-32870/"}