# CVE-2026-32871: FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability

> Attackers can exploit path traversal in URL construction to perform Server-Side Request Forgery and access internal backend APIs.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLSA-2026-1788514996, ECHO-bd91-e96b-0efc, GHSA-vv7q-7jx5-f767, PYSEC-2026-338, ROOT-APP-PYPI-CVE-2026-32871

## What is CVE-2026-32871?

CVE-2026-32871 is a critical server-side request forgery vulnerability in PrefectHQ fastmcp, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FastMCP is a Pythonic way to build MCP servers and clients. Prior to version 3.2.0, the OpenAPIProvider in FastMCP exposes internal APIs to MCP clients by parsing OpenAPI specifications. The RequestDirector class is responsible for constructing HTTP requests to the backend service. A vulnerability exists in the _build_url() method. When an OpenAPI operation defines path parameters (e.g., /api/v1/users/{user_id}), the system directly substitutes parameter values into the URL template string without URL-encoding. Subsequently, urllib.parse.urljoin() resolves the final URL. Since urljoin() interprets ../ sequences as directory traversal, an attacker controlling a path parameter can perform path traversal attacks to escape the intended API prefix and access arbitrary backend endpoints. This results in authenticated SSRF, as requests are sent with the authorization headers configured in the MCP provider. This issue has been patched in version 3.2.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-32871?

3 open source packages ship an affected version, including fastmcp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastmcp` | PyPI | All versions | 3.2.0 |
| `fastmcp` | PyPI | All versions | 3.2.0 |
| `fastmcp` | PyPI | All versions | 3.2.0 |

Products: Jlowin Fastmcp.

## How do I fix CVE-2026-32871?

Upgrade fastmcp to 3.2.0 or later.

## Is CVE-2026-32871 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32871 exists.

## Other vulnerabilities in PrefectHQ fastmcp

- [CVE-2026-27124](https://insights.sbomify.com/CVE-2026-27124/): FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities (high 8.2)
- [CVE-2025-69196](https://insights.sbomify.com/CVE-2025-69196/): FastMCP OAuth Proxy token reuse across MCP servers (high 7.4)
- [CVE-2025-64340](https://insights.sbomify.com/CVE-2025-64340/): FastMCP has a Command Injection vulnerability - Gemini CLI (medium 6.7)
- [CVE-2025-62801](https://insights.sbomify.com/CVE-2025-62801/): FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name (medium 5.4)
- [CVE-2025-62800](https://insights.sbomify.com/CVE-2025-62800/): FastMCP vulnerable to reflected XSS in client's callback page (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32871 and fix it if it is affected.

What it is: CVE-2026-32871 is a critical server-side request forgery vulnerability in PrefectHQ fastmcp, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32871 exists.

Affected packages and fixed versions:
- fastmcp (PyPI): affected all versions; fixed in 3.2.0
- fastmcp (PyPI): affected all versions; fixed in 3.2.0
- fastmcp (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32871/ (Markdown: https://insights.sbomify.com/CVE-2026-32871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32871
- OSV: https://osv.dev/vulnerability/CVE-2026-32871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32871/
Summaries are generated and may contain mistakes; the official description above is the record.
