# CVE-2026-32874: UltraJSON has a Memory Leak parsing large integers allows DoS

> Attackers can cause denial of service by sending JSON with large integers, leading to memory leaks in the UltraJSON library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-32874, ECHO-1418-3756-d634, GHSA-wgvc-ghv9-3pmm, MINI-mq5m-2pgm-4wpx, PYSEC-2026-2291, ROOT-APP-PYPI-CVE-2026-32874, UBUNTU-CVE-2026-32874

## What is CVE-2026-32874?

CVE-2026-32874 is a high-severity denial of service vulnerability in ultrajson, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. Versions 5.4.0 through 5.11.0 contain an accumulating memory leak in JSON parsing large (outside of the range [-2^63, 2^64 - 1]) integers. The leaked memory is a copy of the string form of the integer plus an additional NULL byte. The leak occurs irrespective of whether the integer parses successfully or is rejected due to having more than sys.get_int_max_str_digits() digits, meaning that any sized leak per malicious JSON can be achieved provided that there is no limit on the overall size of the payload. Any service that calls ujson.load()/ujson.loads()/ujson.decode() on untrusted inputs is affected and vulnerable to denial of service attacks. This issue has been fixed in version 5.12.0.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime), CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2026-32874?

3 open source packages ship an affected version, including ujson. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ujson` | PyPI | From 5.4.0 | 5.12.0 |
| `ujson` | PyPI | From 5.4.0 | 5.12.0 |
| `ujson` | PyPI | From 5.4.0 | 5.12.0 |

Products: Ultrajson Project Ultrajson.

## How do I fix CVE-2026-32874?

Upgrade ujson to 5.12.0 or later.

## Is CVE-2026-32874 being exploited?

There is no known exploitation of CVE-2026-32874 in the wild and no public exploit code.

## Other vulnerabilities in ultrajson

- [CVE-2026-44660](https://insights.sbomify.com/CVE-2026-44660/): UltraJSON: Memory Leak in ujson.dump() on Write Failure (high 8.7)
- [CVE-2026-32875](https://insights.sbomify.com/CVE-2026-32875/): UltraJSON has an integer overflow handling large indent leads to buffer overflow or infinite loop (high 7.5)
- [CVE-2026-54911](https://insights.sbomify.com/CVE-2026-54911/): UltraJSON: Malformed/Truncated UTF-8 Accepted and Silently Rewritten in ujson.dumps() (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32874 and fix it if it is affected.

What it is: CVE-2026-32874 is a high-severity denial of service vulnerability in ultrajson, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32874 in the wild and no public exploit code.

Affected packages and fixed versions:
- ujson (PyPI): affected from 5.4.0; fixed in 5.12.0
- ujson (PyPI): affected from 5.4.0; fixed in 5.12.0
- ujson (PyPI): affected from 5.4.0; fixed in 5.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32874/ (Markdown: https://insights.sbomify.com/CVE-2026-32874/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32874
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32874
- OSV: https://osv.dev/vulnerability/CVE-2026-32874

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32874/
Summaries are generated and may contain mistakes; the official description above is the record.
