CVE-2026-32878 Parse Server vulnerable to schema poisoning via prototype pollution in deep copy
Attackers can exploit prototype pollution to inject fields into locked schemas, bypassing security controls and causing permanent data conflicts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32878?
CVE-2026-32878 is a medium-severity code injection vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.20 and 8.6.44, an attacker can bypass the default request keyword denylist protection and the class-level permission for adding fields by sending a crafted request that exploits prototype pollution in the deep copy mechanism. This allows injecting fields into class schemas that have field addition locked down, and can cause permanent schema type conflicts that cannot be resolved even with the master key. In 9.6.0-alpha.20 and 8.6.44, the vulnerable third-party deep copy library has been replaced with a built-in deep clone mechanism that handles prototype properties safely, allowing the existing denylist check to correctly detect and reject the prohibited keyword. No known workarounds are available.
Weakness: CWE-1321
Which versions are affected by CVE-2026-32878?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.44 |
parse-server npm | All versions | 8.6.44 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.20 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.20 |
parse Bitnami | All versions | 8.6.44, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-32878?
Upgrade parse-server to a fixed version for your release line: 8.6.44 or 9.6.0-alpha.20.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-32878 being exploited?
There is no known exploitation of CVE-2026-32878 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-32878, GHSA-9ccr-fpp6-78qf.