# CVE-2026-32878: Parse Server vulnerable to schema poisoning via prototype pollution in deep copy

> Attackers can exploit prototype pollution to inject fields into locked schemas, bypassing security controls and causing permanent data conflicts.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 19 Mar 2026
- **Also known as:** BIT-parse-2026-32878, GHSA-9ccr-fpp6-78qf

## What is CVE-2026-32878?

CVE-2026-32878 is a medium-severity code injection vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.20 and 8.6.44, an attacker can bypass the default request keyword denylist protection and the class-level permission for adding fields by sending a crafted request that exploits prototype pollution in the deep copy mechanism. This allows injecting fields into class schemas that have field addition locked down, and can cause permanent schema type conflicts that cannot be resolved even with the master key. In 9.6.0-alpha.20 and 8.6.44, the vulnerable third-party deep copy library has been replaced with a built-in deep clone mechanism that handles prototype properties safely, allowing the existing denylist check to correctly detect and reject the prohibited keyword. No known workarounds are available.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-32878?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.44 |
| `parse-server` | npm | All versions | 8.6.44 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.20 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.20 |
| `parse` | Bitnami | All versions | 8.6.44, 9.6.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-32878?

Upgrade parse-server to a fixed version for your release line: 8.6.44 or 9.6.0-alpha.20.

## Is CVE-2026-32878 being exploited?

There is no known exploitation of CVE-2026-32878 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32878 and fix it if it is affected.

What it is: CVE-2026-32878 is a medium-severity code injection vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32878 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.44
- parse-server (npm): affected all versions; fixed in 8.6.44
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.20
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.20
- parse (Bitnami): affected all versions; fixed in 8.6.44, 9.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32878/ (Markdown: https://insights.sbomify.com/CVE-2026-32878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32878
- OSV: https://osv.dev/vulnerability/CVE-2026-32878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32878/
Summaries are generated and may contain mistakes; the official description above is the record.
