# CVE-2026-32879: New API has passkey-based secure step-up verification bypass for root-only channel secret disclosure

> Authenticated users can bypass passkey verification to disclose root-only channel secrets in the New API LLM gateway.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-5353-f8fq-65vc, GO-2026-4813

## What is CVE-2026-32879?

CVE-2026-32879 is a medium-severity authentication bypass vulnerability in QuantumNous new-api, published on 23 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Starting in version 0.10.0, a logic flaw in the universal secure verification flow allows an authenticated user with a registered passkey to satisfy secure verification without completing a WebAuthn assertion. As of time of publication, no known patched versions are available. Until a patched release is applied, do not rely on passkey as the step-up method for privileged secure-verification actions; require TOTP/2FA for those actions where operationally possible; or temporarily restrict access to affected secure-verification-protected endpoints.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-32879?

3 open source packages ship an affected version, including github.com/QuantumNous/new-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/QuantumNous/new-api` | Go | From 0.10.0 | None |
| `github.com/QuantumNous/new-api` | Go | From 0.10.0 to 0.11.9-alpha.1 | None |
| `github.com/QuantumNous/new-api` | Go | From 0.10.0 to 0.11.9-alpha.1 | None |

Products: Newapi New Api.

## How do I fix CVE-2026-32879?

Apply a workaround.

## Is CVE-2026-32879 being exploited?

There is no known exploitation of CVE-2026-32879 in the wild and no public exploit code.

## Other vulnerabilities in QuantumNous new-api

- [CVE-2025-55573](https://insights.sbomify.com/CVE-2025-55573/): Cross-site scripting in n/a (high 8.8)
- [CVE-2026-33655](https://insights.sbomify.com/CVE-2026-33655/): New API: SSRF Protection Bypass via Unresolved Hostname in Notification URLs (high 7.7)
- [CVE-2026-25802](https://insights.sbomify.com/CVE-2026-25802/): New API has Potential XSS in its MarkdownRenderer component (high 7.6)
- [CVE-2026-41432](https://insights.sbomify.com/CVE-2026-41432/): New API: Stripe Webhook Signature Bypass via Empty Secret Enables Unlimited Quota Fraud (high 7.1)
- [CVE-2026-42339](https://insights.sbomify.com/CVE-2026-42339/): New API: SSRF Filter Bypass via 0.0.0.0 (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32879 and fix it if it is affected.

What it is: CVE-2026-32879 is a medium-severity authentication bypass vulnerability in QuantumNous new-api, published on 23 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32879 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/QuantumNous/new-api (Go): affected from 0.10.0; no fix listed
- github.com/QuantumNous/new-api (Go): affected from 0.10.0 up to 0.11.9-alpha.1; no fix listed
- github.com/QuantumNous/new-api (Go): affected from 0.10.0 up to 0.11.9-alpha.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32879/ (Markdown: https://insights.sbomify.com/CVE-2026-32879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32879
- OSV: https://osv.dev/vulnerability/CVE-2026-32879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32879/
Summaries are generated and may contain mistakes; the official description above is the record.
