# CVE-2026-32881: ewe has an Overly Permissive List of Allowed Inputs

> Attackers can bypass authentication and hijack sessions by spoofing headers via chunked transfer encoding trailers in the ewe web server.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-9w88-79f8-m3vp

## What is CVE-2026-32881?

CVE-2026-32881 is a medium-severity authentication bypass vulnerability in vshakitskiy ewe, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ewe is a Gleam web server. ewe is a Gleam web server. Versions 0.6.0 through 3.0.4 are vulnerable to authentication bypass or spoofed proxy-trust headers. Chunked transfer encoding trailer handling merges declared trailer fields into req.headers after body parsing, but the denylist only blocks 9 header names.  A malicious client can exploit this by declaring these headers in the Trailer field and appending them after the final chunk, causing request.set_header to overwrite legitimate values (e.g., those set by a reverse proxy). This enables attackers to forge authentication credentials, hijack sessions, bypass IP-based rate limiting, or spoof proxy-trust headers in any downstream middleware that reads headers after ewe.read_body is called. This issue has been fixed in version 3.0.5.

Weakness: CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-32881?

2 open source packages ship an affected version, including ewe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ewe` | Hex | From 0.6.0 | 3.0.5 |
| `ewe` | Hex | From 0.6.0 | 3.0.5 |

Products: Vshakitskiy Ewe.

## How do I fix CVE-2026-32881?

Upgrade ewe to 3.0.5 or later.

## Is CVE-2026-32881 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32881 exists.

## Other vulnerabilities in vshakitskiy ewe

- [CVE-2026-32873](https://insights.sbomify.com/CVE-2026-32873/): ewe: Loop with Unreachable Exit Condition ('Infinite Loop') (high 7.5)
- [CVE-2026-34715](https://insights.sbomify.com/CVE-2026-34715/): ewe Has Improper Neutralization of CRLF Sequences in HTTP Headers (HTTP Request/Response Splitting) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32881 and fix it if it is affected.

What it is: CVE-2026-32881 is a medium-severity authentication bypass vulnerability in vshakitskiy ewe, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32881 exists.

Affected packages and fixed versions:
- ewe (Hex): affected from 0.6.0; fixed in 3.0.5
- ewe (Hex): affected from 0.6.0; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32881/ (Markdown: https://insights.sbomify.com/CVE-2026-32881/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32881
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32881
- OSV: https://osv.dev/vulnerability/CVE-2026-32881

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32881/
Summaries are generated and may contain mistakes; the official description above is the record.
