# CVE-2026-32885: DDEV has ZipSlip path traversal in tar and zip archive extraction

> Attackers can exploit unsanitized archive extraction in DDEV to write files outside intended directories, potentially leading to code execution or data modification.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** GHSA-x2xq-qhjf-5mvg, GO-2026-5735

## What is CVE-2026-32885?

CVE-2026-32885 is a medium-severity path traversal vulnerability in ddev, published on 22 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DDEV is an open-source tool for running local web development environments for PHP and Node.js. Versions prior to 1.25.2 have unsanitized extraction in both `Untar()` and `Unzip()` functions in `pkg/archive/archive.go`. Downloads and extracts archives from remote sources without path validation. Version 1.25.2 patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-32885?

3 open source packages ship an affected version, including github.com/ddev/ddev. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ddev/ddev` | Go | All versions | 1.25.2 |
| `github.com/ddev/ddev` | Go | All versions | 1.25.2 |
| `github.com/ddev/ddev` | Go | All versions | 1.25.2 |

Products: Ddev Ddev.

## How do I fix CVE-2026-32885?

Upgrade github.com/ddev/ddev to 1.25.2 or later.

## Is CVE-2026-32885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32885 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32885 and fix it if it is affected.

What it is: CVE-2026-32885 is a medium-severity path traversal vulnerability in ddev, published on 22 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32885 exists.

Affected packages and fixed versions:
- github.com/ddev/ddev (Go): affected all versions; fixed in 1.25.2
- github.com/ddev/ddev (Go): affected all versions; fixed in 1.25.2
- github.com/ddev/ddev (Go): affected all versions; fixed in 1.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32885/ (Markdown: https://insights.sbomify.com/CVE-2026-32885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32885
- OSV: https://osv.dev/vulnerability/CVE-2026-32885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32885/
Summaries are generated and may contain mistakes; the official description above is the record.
