# CVE-2026-32887: Effect Bug: `AsyncLocalStorage` context lost/contaminated inside Effect fibers under concurrent load with RPC

> Concurrent requests in Effect fibers can leak AsyncLocalStorage context, allowing attackers to read other users' session data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** CLEANSTART-2026-SJ56797, CLEANSTART-2026-XL99311, GHSA-38f7-945m-qr2g, MINI-7w9f-jqxm-5vx2, MINI-mxp7-hw7j-rg33, MINI-p5rm-68w7-fvc7

## What is CVE-2026-32887?

CVE-2026-32887 is a high-severity vulnerability in Effect-TS effect, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Effect is a TypeScript framework that consists of several packages that work together to help build TypeScript applications. Prior to version 3.20.0, when using `RpcServer.toWebHandler` (or `HttpApp.toWebHandlerRuntime`) inside a Next.js App Router route handler, any Node.js `AsyncLocalStorage`-dependent API called from within an Effect fiber can read another concurrent request's context — or no context at all. Under production traffic, `auth()` from `@clerk/nextjs/server` returns a different user's session. Version 3.20.0 contains a fix for the issue.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-32887?

2 open source packages ship an affected version, including effect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `effect` | npm | All versions | 3.20.0 |
| `effect` | npm | All versions | 3.20.0 |

Products: Effectful Effect.

## How do I fix CVE-2026-32887?

Upgrade effect to 3.20.0 or later.

## Is CVE-2026-32887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32887 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32887 and fix it if it is affected.

What it is: CVE-2026-32887 is a high-severity vulnerability in Effect-TS effect, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32887 exists.

Affected packages and fixed versions:
- effect (npm): affected all versions; fixed in 3.20.0
- effect (npm): affected all versions; fixed in 3.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32887/ (Markdown: https://insights.sbomify.com/CVE-2026-32887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32887
- OSV: https://osv.dev/vulnerability/CVE-2026-32887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32887/
Summaries are generated and may contain mistakes; the official description above is the record.
