CVE-2026-32891 Anchorr Privilege Escalation: Jellyseerr User → Anchorr Admin via Stored XSS

Critical 9.1 Published Updated

Stored XSS in Anchorr allows attackers to steal admin tokens and API keys, leading to full administrative takeover of the bot and integrated services.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-32891?

CVE-2026-32891 is a critical cross-site scripting vulnerability in openVESSL Anchorr, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Anchorr is a Discord bot for requesting movies and TV shows and receiving notifications when items are added to a media server. Versions 1.4.1 and below contain a stored XSS vulnerability in the Jellyseerr user selector. Jellyseerr allows any account holder to execute arbitrary JavaScript in the Anchorr admin's browser session. The injected script calls the authenticated /api/config endpoint - which returns the full application configuration in plaintext. This allows the attacker to forge a valid Anchorr session token and gain full admin access to the dashboard with no knowledge of the admin password. The same response also exposes the API keys and tokens for every integrated service, resulting in simultaneous account takeover of the Jellyfin media server (via JELLYFIN_API_KEY), the Jellyseerr request manager (via JELLYSEERR_API_KEY), and the Discord bot (via DISCORD_TOKEN). This issue has been fixed in version 1.4.2.

Weakness: CWE-80, CWE-311, CWE-212

Which versions are affected by CVE-2026-32891?

It affects 1 product.

Products include Openvessl Anchorr.

How do I fix CVE-2026-32891?

No fix has been published for CVE-2026-32891 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-32891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32891 exists.

Sources

Also known as GHSA-6mg4-788h-7g9g.

Is CVE-2026-32891 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free