# CVE-2026-32891: Anchorr Privilege Escalation: Jellyseerr User → Anchorr Admin via Stored XSS

> Stored XSS in Anchorr allows attackers to steal admin tokens and API keys, leading to full administrative takeover of the bot and integrated services.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-6mg4-788h-7g9g

## What is CVE-2026-32891?

CVE-2026-32891 is a critical cross-site scripting vulnerability in openVESSL Anchorr, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Anchorr is a Discord bot for requesting movies and TV shows and receiving notifications when items are added to a media server. Versions 1.4.1 and below contain a stored XSS vulnerability in the Jellyseerr user selector. Jellyseerr allows any account holder to execute arbitrary JavaScript in the Anchorr admin's browser session. The injected script calls the authenticated /api/config endpoint - which returns the full application configuration in plaintext. This allows the attacker to forge a valid Anchorr session token and gain full admin access to the dashboard with no knowledge of the admin password. The same response also exposes the API keys and tokens for every integrated service, resulting in simultaneous account takeover of the Jellyfin media server (via JELLYFIN_API_KEY), the Jellyseerr request manager (via JELLYSEERR_API_KEY), and the Discord bot (via DISCORD_TOKEN). This issue has been fixed in version 1.4.2.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-311 (Missing Encryption of Sensitive Data), CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2026-32891?

It affects 1 product.


Products: Openvessl Anchorr.

## How do I fix CVE-2026-32891?

No fix has been published for CVE-2026-32891 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32891 exists.

## Other vulnerabilities in openVESSL Anchorr

- [CVE-2026-32890](https://insights.sbomify.com/CVE-2026-32890/): Cross-site scripting in Anchorr (critical 9.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32891 and fix it if it is affected.

What it is: CVE-2026-32891 is a critical cross-site scripting vulnerability in openVESSL Anchorr, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32891 exists.

Affected product: openVESSL Anchorr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32891/ (Markdown: https://insights.sbomify.com/CVE-2026-32891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32891
- OSV: https://osv.dev/vulnerability/CVE-2026-32891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32891/
Summaries are generated and may contain mistakes; the official description above is the record.
