CVE-2026-32906 OpenClaw < 2026.5.12 - Privilege Escalation in Slack Plugin Approvals via Exec Approver Gate
Attackers with limited exec permissions can bypass approval gates to approve plugin actions, leading to privilege escalation in OpenClaw.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32906?
CVE-2026-32906 is a low-severity vulnerability in Openclaw Openclaw, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.5.12 contains a privilege escalation vulnerability in Slack plugin approvals that allows exec-authorized users to resolve plugin approvals through the exec approver gate. Attackers with limited exec approval permissions can bypass intended approval splits to approve plugin actions outside operator configuration.
Weakness: CWE-863
Which versions are affected by CVE-2026-32906?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.5.12 |
openclaw npm | All versions | 2026.5.12 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-32906?
Upgrade openclaw to 2026.5.12 or later.
Is CVE-2026-32906 being exploited?
There is no known exploitation of CVE-2026-32906 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-6c56-hgvp-5v87, GHSA-wv26-j37q-2g7p, MINI-g23r-qpcw-f838, MINI-jfp9-h54j-x4j9.