CVE-2026-32913 OpenClaw < 2026.3.7 - Custom Authorization Header Leakage via Cross-Origin Redirects
Attackers can intercept sensitive API keys and tokens by triggering cross-origin redirects in the OpenClaw library's fetch guard.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32913?
CVE-2026-32913 is a high-severity vulnerability in Openclaw Openclaw, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenClaw before 2026.3.7 contains an improper header validation vulnerability in fetchWithSsrFGuard that forwards custom authorization headers across cross-origin redirects. Attackers can trigger redirects to different origins to intercept sensitive headers like X-Api-Key and Private-Token intended for the original destination.
Weakness: CWE-522
Which versions are affected by CVE-2026-32913?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.7 |
openclaw npm | All versions | 2026.3.7 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-32913?
Upgrade openclaw to 2026.3.7 or later.
Is CVE-2026-32913 being exploited?
There is no known exploitation of CVE-2026-32913 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-6mgf-v5j7-45cr, MINI-w7hw-39qg-r8vg.