CVE-2026-32916 OpenClaw 2026.3.7 < 2026.3.11 - Authorization Bypass in Plugin Subagent Routes via Synthetic Admin Scopes

Critical 9.2 Published Updated

Remote unauthenticated attackers can bypass authorization to execute privileged gateway actions like session deletion and agent execution via plugin subagent routes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32916?

CVE-2026-32916 is a critical authentication bypass vulnerability in Openclaw Openclaw, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw versions 2026.3.7 before 2026.3.11 contain an authorization bypass vulnerability where plugin subagent routes execute gateway methods through a synthetic operator client with broad administrative scopes. Remote unauthenticated requests to plugin-owned routes can invoke runtime.subagent methods to perform privileged gateway actions including session deletion and agent execution.

Weakness: CWE-266

Which versions are affected by CVE-2026-32916?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.3.72026.3.11
openclaw npmFrom 2026.3.72026.3.11

Products include Openclaw Openclaw.

How do I fix CVE-2026-32916?

Upgrade openclaw to 2026.3.11 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-32916 being exploited?

There is no known exploitation of CVE-2026-32916 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-xw77-45gv-p728, MINI-qvmq-xcx6-7m63, MINI-rp3g-wfmv-q233.

Is CVE-2026-32916 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free