# CVE-2026-32916: OpenClaw 2026.3.7 < 2026.3.11 - Authorization Bypass in Plugin Subagent Routes via Synthetic Admin Scopes

> Remote unauthenticated attackers can bypass authorization to execute privileged gateway actions like session deletion and agent execution via plugin subagent routes.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-xw77-45gv-p728, MINI-qvmq-xcx6-7m63, MINI-rp3g-wfmv-q233

## What is CVE-2026-32916?

CVE-2026-32916 is a critical authentication bypass vulnerability in Openclaw Openclaw, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenClaw versions 2026.3.7 before 2026.3.11 contain an authorization bypass vulnerability where plugin subagent routes execute gateway methods through a synthetic operator client with broad administrative scopes. Remote unauthenticated requests to plugin-owned routes can invoke runtime.subagent methods to perform privileged gateway actions including session deletion and agent execution.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-32916?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.3.7 | 2026.3.11 |
| `openclaw` | npm | From 2026.3.7 | 2026.3.11 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-32916?

Upgrade openclaw to 2026.3.11 or later.

## Is CVE-2026-32916 being exploited?

There is no known exploitation of CVE-2026-32916 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32916 and fix it if it is affected.

What it is: CVE-2026-32916 is a critical authentication bypass vulnerability in Openclaw Openclaw, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32916 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.3.7; fixed in 2026.3.11
- openclaw (npm): affected from 2026.3.7; fixed in 2026.3.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32916/ (Markdown: https://insights.sbomify.com/CVE-2026-32916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32916
- OSV: https://osv.dev/vulnerability/CVE-2026-32916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32916/
Summaries are generated and may contain mistakes; the official description above is the record.
