CVE-2026-32935 phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

High 8.2 Published Updated

Attackers can exploit timing differences in AES-CBC unpadding to perform padding oracle attacks, potentially revealing plaintext data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32935?

CVE-2026-32935 is a high-severity vulnerability in phpseclib, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

Weakness: CWE-208

Which versions are affected by CVE-2026-32935?

6 open source packages ship an affected version, including phpseclib/phpseclib. It affects 1 product.

PackageAffectedFixed in
phpseclib/phpseclib PackagistFrom 0.1.11.0.27
phpseclib/phpseclib PackagistFrom 0.1.11.0.27
phpseclib/phpseclib PackagistFrom 2.0.02.0.52
phpseclib/phpseclib PackagistFrom 2.0.02.0.52
phpseclib/phpseclib PackagistFrom 3.0.03.0.50
phpseclib/phpseclib PackagistFrom 3.0.03.0.50

Products include Phpseclib Phpseclib.

How do I fix CVE-2026-32935?

Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.27, 2.0.52 or 3.0.50.

Is CVE-2026-32935 being exploited?

There is no known exploitation of CVE-2026-32935 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-32935, DSA-6185-1, DSA-6186-1, DSA-6187-1, GHSA-94g3-g5v7-q4jg, UBUNTU-CVE-2026-32935.

Is CVE-2026-32935 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free