# CVE-2026-32936: CoreDNS DoH GET path missing size validation causes CPU and memory amplification

> Remote attackers can cause denial of service in CoreDNS by sending oversized DNS-over-HTTPS GET requests that trigger excessive CPU and memory usage.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 5 May 2026
- **Also known as:** AZL-85724, CLEANSTART-2026-BP22631, CLEANSTART-2026-SO59114, ECHO-3575-11f2-ad06, GHSA-63cw-r7xf-jmwr, GO-2026-5164, MINI-24v5-8r2v-8982, MINI-24vr-cfvf-6vq4, MINI-5q9m-qpjh-vc3h, MINI-6fh9-q85w-9m35, MINI-7fpq-2p4c-phf8, MINI-85qx-q35h-h42h, MINI-898q-7gf9-4p7x, MINI-9x78-9c5c-hq88, MINI-fprp-x786-gh94, MINI-fw5v-v933-96mg, MINI-q3fj-g79g-mj65, MINI-q67j-h49x-922p, MINI-q784-9w9x-9w26, MINI-r7hr-g3h5-q6mm, MINI-r886-9c2q-mqxc, MINI-rxf2-jw6v-8p8g, MINI-w7wc-286g-ww6g, MINI-wqhg-86q8-988q, MINI-xmp9-h5g2-rpx2, MINI-xxwh-qp95-w9pg

## What is CVE-2026-32936?

CVE-2026-32936 is a high-severity denial of service vulnerability in coredns, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CoreDNS is a DNS server that chains plugins. In versions prior to 1.14.3, the DNS-over-HTTPS (DoH) GET path accepts oversized dns= query parameter values and performs URL query parsing, base64 decoding, and DNS message unpacking before rejecting the request. Unlike the POST path, which applies a bounded read via http.MaxBytesReader limited to 65536 bytes, the GET path has no equivalent size validation before expensive processing. A remote, unauthenticated attacker can repeatedly send oversized DoH GET requests to force high CPU usage, large transient memory allocations, and elevated garbage-collection pressure, leading to denial of service. This issue has been fixed in version 1.14.3.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-32936?

3 open source packages ship an affected version, including github.com/coredns/coredns. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coredns/coredns` | Go | All versions | 1.14.3 |
| `github.com/coredns/coredns` | Go | All versions | 1.14.3 |
| `github.com/coredns/coredns` | Go | All versions | 1.14.3 |

Products: Coredns.io Coredns.

## How do I fix CVE-2026-32936?

Upgrade github.com/coredns/coredns to 1.14.3 or later.

## Is CVE-2026-32936 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32936 exists.

## Other vulnerabilities in coredns

- [CVE-2026-32934](https://insights.sbomify.com/CVE-2026-32934/): CoreDNS DNS-over-QUIC unbounded goroutine growth leads to denial of service (high 8.7)
- [CVE-2026-33190](https://insights.sbomify.com/CVE-2026-33190/): CoreDNS TSIG authentication bypass on encrypted DNS transports (high 8.7)
- [CVE-2026-33489](https://insights.sbomify.com/CVE-2026-33489/): CoreDNS transfer plugin subzone ACL bypass via lexicographic zone comparison (high 8.2)
- [CVE-2026-35579](https://insights.sbomify.com/CVE-2026-35579/): CoreDNS TSIG authentication bypass on gRPC, QUIC, DoH, and DoH3 transports (high 8.2)
- [CVE-2026-26017](https://insights.sbomify.com/CVE-2026-26017/): CoreDNS ACL Bypass (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32936 and fix it if it is affected.

What it is: CVE-2026-32936 is a high-severity denial of service vulnerability in coredns, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32936 exists.

Affected packages and fixed versions:
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.3
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.3
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32936/ (Markdown: https://insights.sbomify.com/CVE-2026-32936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32936
- OSV: https://osv.dev/vulnerability/CVE-2026-32936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32936/
Summaries are generated and may contain mistakes; the official description above is the record.
