# CVE-2026-32937: free5GC CHF has Out-of-Bounds Slice Access that Leads to DoS

> Authenticated attackers can trigger server panics in free5GC CHF via out-of-bounds slice access, causing service disruption and log flooding.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-6g43-577r-wf4x, GO-2026-4750

## What is CVE-2026-32937?

CVE-2026-32937 is a high-severity denial of service vulnerability in Free5gc Free5gc, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

free5GC is an open source 5G core network. free5GC CHF prior to version 1.2.2 has an out-of-bounds slice access vulnerability in the CHF `nchf-convergedcharging` service. A valid authenticated request to PUT `/nchf-convergedcharging/v3/recharging/:ueId?ratingGroup=...` can trigger a server-side panic in `github.com/free5gc/chf/internal/sbi.(*Server).RechargePut(...)` due to an out-of-range slice access. In the reported runtime, Gin recovery converts the panic into HTTP 500, but the recharge path remains remotely panic-triggerable and can be abused repeatedly to degrade recharge functionality and flood logs. In deployments without equivalent recovery handling, this panic may cause more severe service disruption. free5GC CHF patches the issue. Some workarounds are available: Restrict access to the `nchf-convergedcharging` recharge endpoint to strictly trusted NF callers only; apply rate limiting or network ACLs in front of the CHF SBI interface to reduce repeated panic-trigger attempts; if the recharge API is not required, temporarily disable or block external reachability to this route; and/or ensure panic recovery, monitoring, and alerting are enabled.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-32937?

3 open source packages ship an affected version, including github.com/free5gc/chf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/chf` | Go | All versions | 1.2.2 |
| `github.com/free5gc/chf` | Go | All versions | 1.2.2 |
| `github.com/free5gc/chf` | Go | All versions | 1.2.2 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-32937?

Upgrade github.com/free5gc/chf to 1.2.2 or later.

## Is CVE-2026-32937 being exploited?

There is no known exploitation of CVE-2026-32937 in the wild and no public exploit code.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32937 and fix it if it is affected.

What it is: CVE-2026-32937 is a high-severity denial of service vulnerability in Free5gc Free5gc, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32937 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/free5gc/chf (Go): affected all versions; fixed in 1.2.2
- github.com/free5gc/chf (Go): affected all versions; fixed in 1.2.2
- github.com/free5gc/chf (Go): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32937/ (Markdown: https://insights.sbomify.com/CVE-2026-32937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32937
- OSV: https://osv.dev/vulnerability/CVE-2026-32937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32937/
Summaries are generated and may contain mistakes; the official description above is the record.
