CVE-2026-32943 Parse Server has a password reset token single-use bypass via concurrent requests

Low 2.3 Published Updated

An attacker can race password reset requests to bypass single-use token enforcement, potentially taking over user accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-32943?

CVE-2026-32943 is a low-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.28 and 8.6.48, the password reset mechanism does not enforce single-use guarantees for reset tokens. When a user requests a password reset, the generated token can be consumed by multiple concurrent requests within a short time window. An attacker who has intercepted a password reset token can race the legitimate user's password reset request, causing both requests to succeed. This may result in the legitimate user believing their password was changed successfully while the attacker's password takes effect instead. All Parse Server deployments that use the password reset feature are affected. Starting in versions 9.6.0-alpha.28 and 8.6.48, the password reset token is now atomically validated and consumed as part of the password update operation. The database query that updates the password includes the reset token as a condition, ensuring that only one concurrent request can successfully consume the token. Subsequent requests using the same token will fail because the token has already been cleared. There is no known workaround other than upgrading.

Weakness: CWE-367

Which versions are affected by CVE-2026-32943?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.48
parse-server npmAll versions8.6.48
parse-server npmFrom 9.0.09.6.0-alpha.28
parse-server npmFrom 9.0.09.6.0-alpha.28
parse BitnamiAll versions8.6.48, 9.6.0

Products include Parseplatform Parse-Server.

How do I fix CVE-2026-32943?

Upgrade parse-server to a fixed version for your release line: 8.6.48 or 9.6.0-alpha.28.

Is CVE-2026-32943 being exploited?

There is no known exploitation of CVE-2026-32943 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2026-32943, GHSA-r3xq-68wh-gwvh.

Is CVE-2026-32943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free