# CVE-2026-32943: Parse Server has a password reset token single-use bypass via concurrent requests

> An attacker can race password reset requests to bypass single-use token enforcement, potentially taking over user accounts.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 19 Mar 2026
- **Also known as:** BIT-parse-2026-32943, GHSA-r3xq-68wh-gwvh

## What is CVE-2026-32943?

CVE-2026-32943 is a low-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.28 and 8.6.48, the password reset mechanism does not enforce single-use guarantees for reset tokens. When a user requests a password reset, the generated token can be consumed by multiple concurrent requests within a short time window. An attacker who has intercepted a password reset token can race the legitimate user's password reset request, causing both requests to succeed. This may result in the legitimate user believing their password was changed successfully while the attacker's password takes effect instead. All Parse Server deployments that use the password reset feature are affected. Starting in versions 9.6.0-alpha.28 and 8.6.48, the password reset token is now atomically validated and consumed as part of the password update operation. The database query that updates the password includes the reset token as a condition, ensuring that only one concurrent request can successfully consume the token. Subsequent requests using the same token will fail because the token has already been cleared. There is no known workaround other than upgrading.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-32943?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.48 |
| `parse-server` | npm | All versions | 8.6.48 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.28 |
| `parse-server` | npm | From 9.0.0 | 9.6.0-alpha.28 |
| `parse` | Bitnami | All versions | 8.6.48, 9.6.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-32943?

Upgrade parse-server to a fixed version for your release line: 8.6.48 or 9.6.0-alpha.28.

## Is CVE-2026-32943 being exploited?

There is no known exploitation of CVE-2026-32943 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32943 and fix it if it is affected.

What it is: CVE-2026-32943 is a low-severity vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32943 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.48
- parse-server (npm): affected all versions; fixed in 8.6.48
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.28
- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.28
- parse (Bitnami): affected all versions; fixed in 8.6.48, 9.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32943/ (Markdown: https://insights.sbomify.com/CVE-2026-32943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32943
- OSV: https://osv.dev/vulnerability/CVE-2026-32943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32943/
Summaries are generated and may contain mistakes; the official description above is the record.
