CVE-2026-32944 Parse Server crash via deeply nested query condition operators
An unauthenticated attacker can crash the Parse Server process by sending a request with deeply nested query operators, requiring an upgrade and configuration change to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32944?
CVE-2026-32944 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.
Weakness: CWE-674
Which versions are affected by CVE-2026-32944?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.45 |
parse-server npm | All versions | 8.6.45 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.21 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.21 |
parse Bitnami | All versions | 8.6.45, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-32944?
Upgrade parse-server to a fixed version for your release line: 8.6.45 or 9.6.0-alpha.21.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-32944 being exploited?
There is no known exploitation of CVE-2026-32944 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-32944, GHSA-9xp9-j92r-p88v.