# CVE-2026-32971: OpenClaw < 2026.3.11 - Node-Host Approval UI Mismatch Allows Execution of Unintended Commands

> Attackers can execute arbitrary local code by tricking operators into approving misleading command text in the OpenClaw node-host approval UI.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-rw39-5899-8mxp, MINI-87h3-4hcg-j7hf, MINI-jq2j-4xhx-8ff5

## What is CVE-2026-32971?

CVE-2026-32971 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenClaw before 2026.3.11 contains an approval-integrity vulnerability in node-host system.run approvals that displays extracted shell payloads instead of the executed argv. Attackers can place wrapper binaries and induce wrapper-shaped commands to execute local code after operators approve misleading command text.

Weakness: CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2026-32971?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.3.11 |
| `openclaw` | npm | All versions | 2026.3.11 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-32971?

Upgrade openclaw to 2026.3.11 or later.

## Is CVE-2026-32971 being exploited?

There is no known exploitation of CVE-2026-32971 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32971 and fix it if it is affected.

What it is: CVE-2026-32971 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32971 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.3.11
- openclaw (npm): affected all versions; fixed in 2026.3.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32971/ (Markdown: https://insights.sbomify.com/CVE-2026-32971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32971
- OSV: https://osv.dev/vulnerability/CVE-2026-32971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32971/
Summaries are generated and may contain mistakes; the official description above is the record.
