CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Attackers can bypass approval checks in OpenClaw by rewriting scripts after approval, leading to arbitrary code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-32978?
CVE-2026-32978 is a critical vulnerability in Openclaw Openclaw, published on 29 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
OpenClaw before 2026.3.11 contains an approval integrity vulnerability where system.run approvals fail to bind mutable file operands for certain script runners like tsx and jiti. Attackers can obtain approval for benign script commands, rewrite referenced scripts on disk, and execute modified code under the approved run context.
Weakness: CWE-863
Which versions are affected by CVE-2026-32978?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.11 |
openclaw npm | All versions | 2026.3.11 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-32978?
Upgrade openclaw to 2026.3.11 or later.
Is CVE-2026-32978 being exploited?
There is no known exploitation of CVE-2026-32978 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-22172 OpenClaw < 2026.3.12 - Scope Elevation in WebSocket Shared-Auth Connections
Sources
Also known as GHSA-qc36-x95h-7j53, MINI-8hgr-vqxj-447r, MINI-x4wv-cfw3-ccjp.