CVE-2026-32990 Apache Tomcat: Fix for CVE-2025-66614 is incomplete
An incomplete fix for a previous input validation flaw in Apache Tomcat may allow unexpected behavior, requiring users to upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32990?
CVE-2026-32990 is a medium-severity vulnerability in Apache Tomcat, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614.
This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115.
Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-32990?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.15 | 11.0.20 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.15 | 11.0.20 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.113 | 9.0.116 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.113 | 9.0.116 |
13 more packages
tomcat Bitnami | From 9.0.13 | 9.0.116, 10.1.53, 11.0.20 |
org.apache.tomcat:tomcat Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat Maven | From 11.0.15 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 11.0.15 | 11.0.20 |
org.apache.tomcat:tomcat Maven | From 9.0.113 | 9.0.116 |
org.apache.tomcat:tomcat Maven | From 9.0.113 | 9.0.116 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.50 | 10.1.53 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.15 | 11.0.20 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.15 | 11.0.20 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.113 | 9.0.116 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.113 | 9.0.116 |
Products include Apache Tomcat.
How do I fix CVE-2026-32990?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.53, 11.0.20 or 9.0.116.
Is CVE-2026-32990 being exploited?
There is no known exploitation of CVE-2026-32990 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-32990, CLEANSTART-2026-AM77386, CLEANSTART-2026-UA26189, DEBIAN-CVE-2026-32990, GHSA-8mc5-53m5-3qj2, MINI-g3gc-pmh5-c69p and 4 more.