# CVE-2026-33001: Jenkins has a link following vulnerability allows arbitrary file creation

> Attackers with configure permissions can exploit symlink handling in archive extraction to write arbitrary files, enabling malicious script deployment.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 9 Sep 2026
- **Also known as:** BIT-jenkins-2026-33001, GHSA-r6qv-frpc-q66c, MINI-2cc2-qwm4-28mj, MINI-9fxm-jf7m-f835, MINI-ggfv-34mc-4hfw, MINI-gxww-9vmx-w34q, MINI-hf8h-p73h-3wh9, MINI-r8xf-35p5-g845

## What is CVE-2026-33001?

CVE-2026-33001 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.554 and earlier, LTS 2.541.2 and earlier does not safely handle symbolic links during the extraction of .tar and .tar.gz archives, allowing crafted archives to write files to arbitrary locations on the filesystem, restricted only by file system access permissions of the user running Jenkins.
This can be exploited to deploy malicious scripts or plugins on the controller by attackers with Item/Configure permission, or able to control agent processes.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-33001?

3 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.555 |
| `jenkins` | Bitnami | All versions | 2.541.3, 2.555.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-33001?

Upgrade org.jenkins-ci.main:jenkins-core to 2.555 or later.

## Is CVE-2026-33001 being exploited?

There is no known exploitation of CVE-2026-33001 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33001 and fix it if it is affected.

What it is: CVE-2026-33001 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33001 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.555
- jenkins (Bitnami): affected all versions; fixed in 2.541.3, 2.555.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33001/ (Markdown: https://insights.sbomify.com/CVE-2026-33001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33001
- OSV: https://osv.dev/vulnerability/CVE-2026-33001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33001/
Summaries are generated and may contain mistakes; the official description above is the record.
