# CVE-2026-33003: Jenkins LoadNinja Plugin stores LoadNinja API keys unencrypted in job config.xml files

> Attackers with extended read permissions or file system access can view unencrypted LoadNinja API keys stored in Jenkins job configurations.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** GHSA-qqjr-hf5h-jx3q

## What is CVE-2026-33003?

CVE-2026-33003 is a medium-severity vulnerability in Jenkins LoadNinja Plugin, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins LoadNinja Plugin 2.1 and earlier stores LoadNinja API keys unencrypted in job config.xml files on the Jenkins controller where they can be viewed by users with Item/Extended Read permission or access to the Jenkins controller file system.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2026-33003?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:loadninja. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:loadninja` | Maven | All versions | 2.2 |
| `org.jenkins-ci.plugins:loadninja` | Maven | All versions | 2.2 |

Products: Jenkins Loadninja.

## How do I fix CVE-2026-33003?

Upgrade org.jenkins-ci.plugins:loadninja to 2.2 or later.

## Is CVE-2026-33003 being exploited?

There is no known exploitation of CVE-2026-33003 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins LoadNinja Plugin

- [CVE-2026-33004](https://insights.sbomify.com/CVE-2026-33004/): Jenkins LoadNinja Plugin does not mask LoadNinja API keys displayed on the job configuration form (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33003 and fix it if it is affected.

What it is: CVE-2026-33003 is a medium-severity vulnerability in Jenkins LoadNinja Plugin, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33003 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:loadninja (Maven): affected all versions; fixed in 2.2
- org.jenkins-ci.plugins:loadninja (Maven): affected all versions; fixed in 2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33003/ (Markdown: https://insights.sbomify.com/CVE-2026-33003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33003
- OSV: https://osv.dev/vulnerability/CVE-2026-33003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33003/
Summaries are generated and may contain mistakes; the official description above is the record.
