CVE-2026-33006 Apache HTTP Server: mod_auth_digest timing attack

Medium 4.8 Published Updated

Remote attackers can bypass Digest authentication in Apache HTTP Server via a timing attack, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33006?

CVE-2026-33006 is a medium-severity authentication bypass vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A timing attack against mod_auth_digest in Apache HTTP Server 2.4.66 allows a bypass of Digest authentication by a remote attacker.

Users are recommended to upgrade to version 2.4.67, which fixes this issue.

Weakness: CWE-208

Which versions are affected by CVE-2026-33006?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.67

Products include Apache Http Server.

How do I fix CVE-2026-33006?

Upgrade apache to 2.4.67 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-33006 being exploited?

There is no known exploitation of CVE-2026-33006 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-33006, AZL-86013, BELL-CVE-2026-33006, BIT-apache-2026-33006, DEBIAN-CVE-2026-33006, GHSA-r3x7-65m7-5p92 and 2 more.

Is CVE-2026-33006 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free